5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Sroberts1789

New Member
Joined
Oct 29, 2020
Messages
2
Reaction score
0
Okay so I have a 2016 ram and my check engine light has been on for awhile throwing a code for an active grill shutter. Dealership said it’s not that big of an issue so I didn’t worry about it, then I went to trade my truck in and they were gonna knock $1200 off trade in for it. So I decided to just replace the shutters myself. Replaced it and still the same thing. But I noticed when the truck was off I could still hear the motor running. Then I unplugged the battery and plugged it back in, light went away. Killed the truck and started twice and still nothing. Next morning went out and the light was back. Really frustrated because the dealer is gonna charge another diagnostic charge and I’m trying to figure this out, if they’re is any solution or maybe a recall?
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,367
Reaction score
954
Location
Michigan
Okay so I have a 2016 ram and my check engine light has been on for awhile throwing a code for an active grill shutter. Dealership said it’s not that big of an issue so I didn’t worry about it, then I went to trade my truck in and they were gonna knock $1200 off trade in for it. So I decided to just replace the shutters myself. Replaced it and still the same thing. But I noticed when the truck was off I could still hear the motor running. Then I unplugged the battery and plugged it back in, light went away. Killed the truck and started twice and still nothing. Next morning went out and the light was back. Really frustrated because the dealer is gonna charge another diagnostic charge and I’m trying to figure this out, if they’re is any solution or maybe a recall?
We certainly understand why this would be concerning. If you are not able to determine a solution based on suggestions from fellow forum members and you decide to address this with your Ram dealer, please be sure to follow up with us via private message. We would be more than willing to escalate your situation to a specialist who can work alongside you and your dealer while your truck is in service.

Mark
RamCares
 

mikeru82

Ram Guru
Joined
Nov 18, 2019
Messages
1,846
Reaction score
1,133
Okay so I have a 2016 ram and my check engine light has been on for awhile throwing a code for an active grill shutter. Dealership said it’s not that big of an issue so I didn’t worry about it, then I went to trade my truck in and they were gonna knock $1200 off trade in for it. So I decided to just replace the shutters myself. Replaced it and still the same thing. But I noticed when the truck was off I could still hear the motor running. Then I unplugged the battery and plugged it back in, light went away. Killed the truck and started twice and still nothing. Next morning went out and the light was back. Really frustrated because the dealer is gonna charge another diagnostic charge and I’m trying to figure this out, if they’re is any solution or maybe a recall?
Since this is a 5th gen forum, I seriously doubt anyone here has messed with the active grille shutters on their trucks. Most people here still have the factory warranty. Lots of us have upgraded from 4th gens, so it's possible someone here might have a suggestion. But you might have more luck posting in 4th gen forums.
 

Sroberts1789

New Member
Joined
Oct 29, 2020
Messages
2
Reaction score
0
We certainly understand why this would be concerning. If you are not able to determine a solution based on suggestions from fellow forum members and you decide to address this with your Ram dealer, please be sure to follow up with us via private message. We would be more than willing to escalate your situation to a specialist who can work alongside you and your dealer while your truck is in service.

Mark
RamCares
Well I’m taking it in today at the local ram dealership. I told them everything that I tried to troubleshoot on my end, replaced the whole shudder twice, looked at the plug and checked for burnt spots in case of a short. But everything looked brand new. My truck only has 42500 miles on it, but my 3 yr warranty is up. They’re gonna check the computer and hopefully see the issue.
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,367
Reaction score
954
Location
Michigan
Well I’m taking it in today at the local ram dealership. I told them everything that I tried to troubleshoot on my end, replaced the whole shudder twice, looked at the plug and checked for burnt spots in case of a short. But everything looked brand new. My truck only has 42500 miles on it, but my 3 yr warranty is up. They’re gonna check the computer and hopefully see the issue.
If you would be interested in having a case escalated to a customer care specialist for further support as you work with your dealer, please do not hesitate to send us a private message. We are more than willing to provide support!

Mark
RamCares
 

Greg10yes

Member
Joined
Apr 8, 2020
Messages
21
Reaction score
15
Location
Medina, OH
Did the dealership fix the check engine light? I am having the same issues, truck has 55k on it, I have replaced the active grill shutter, both the new one and old one act the same way, checked the wires and connector.
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,367
Reaction score
954
Location
Michigan
Did the dealership fix the check engine light? I am having the same issues, truck has 55k on it, I have replaced the active grill shutter, both the new one and old one act the same way, checked the wires and connector.
We are sorry to hear that you are experiencing these similar concerns with your RAM, Greg. Our team would appreciate the opportunity to assist you via private messages if you do decide to bring this to the attention of your dealer.

Kathryn
RamCares
 

UnloosedChewtoy

5thGenRams Supporter
Site Supporter
Joined
Jul 22, 2020
Messages
505
Reaction score
385
Location
South Dakota
Well I’m taking it in today at the local ram dealership. I told them everything that I tried to troubleshoot on my end, replaced the whole shudder twice, looked at the plug and checked for burnt spots in case of a short. But everything looked brand new. My truck only has 42500 miles on it, but my 3 yr warranty is up. They’re gonna check the computer and hopefully see the issue.

Sorry to hear about your issue. As @mikeru82 stated, if you want good advice, I'd definitely post the question in the correct category.

Hope you get it resolved quickly!
 

kittyjo

Well-Known Member
Joined
Nov 9, 2018
Messages
424
Reaction score
120
Had the check engine light come on which resulted in remote start disabled and active grill shutters problem.... took it in today and they are ordering new active grill. Only have 32k miles on truck.. I’ll know what parts exactly this week..
 
Last edited:

Greg10yes

Member
Joined
Apr 8, 2020
Messages
21
Reaction score
15
Location
Medina, OH
I was having the same issue, replaced the active grill shutter for a mere $350, didn’t fix the problem, turned out it was the active air dam. Dealer charged me $800.
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,367
Reaction score
954
Location
Michigan
Had the check engine light come on which resulted in remote start disabled and active grill shutters problem.... took it in today and they are ordering new active grill. Only have 32k miles on truck.. I’ll know what parts exactly this week..
We are deeply sorry for the trouble, @kittyjo. Please be sure to keep us posted on your dealer service. We would be more than willing to escalate a case on your behalf to a specialist for further support through that process. Please do not hesitate to follow up via private message with any questions.

Kathryn
Ram Cares
 

mikeru82

Ram Guru
Joined
Nov 18, 2019
Messages
1,846
Reaction score
1,133
I was having the same issue, replaced the active grill shutter for a mere $350, didn’t fix the problem, turned out it was the active air dam. Dealer charged me $800.
Your active air dam was throwing a code? That's strange to me because I've removed the active air dam from both of our 5th gens, and neither of us has seen a code for this. We've been running for almost a year without them. Other members here have also removed the active air dams with no issues or trouble codes.
 

Greg10yes

Member
Joined
Apr 8, 2020
Messages
21
Reaction score
15
Location
Medina, OH
That is what the dealer told me when they charged me $800. I had replaced the active grill shutters after getting a code I think it was U11E9 which from looking at the forum was the BCM not seeing the AGS. I checked the connector and finally broke down and replaced the AGS.
 

kittyjo

Well-Known Member
Joined
Nov 9, 2018
Messages
424
Reaction score
120
Here is warranty paperwork... dealer was very polite and professional .
 

Attachments

  • image.jpg
    image.jpg
    157.7 KB · Views: 13

Users who are viewing this thread

Top