5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Power Surge on USB

TSMI

New Member
Joined
May 6, 2023
Messages
2
Reaction score
1
Today when I started the engine I received an on screen notification stating "Power Surge on USB hub detected. Please disconnect the device." I unplugged all USBs but the message remains. Has anyone else run into this issue?
 

Darksteel165

Legendary member
Joined
Dec 16, 2021
Messages
6,111
Reaction score
3,672
Location
Massachusetts
Today when I started the engine I received an on screen notification stating "Power Surge on USB hub detected. Please disconnect the device." I unplugged all USBs but the message remains. Has anyone else run into this issue?
Was your truck left in the hot sun hitting the media hub (radio area)? I know those are prone to overheat
 

Duane_L

New Member
Joined
Aug 4, 2022
Messages
2
Reaction score
5
Same issue on mine today... I'll see if after it cools off if it goes away...
 

Randboye

Active Member
Joined
May 2, 2021
Messages
174
Reaction score
125
Location
TEXAS
Today when I started the engine I received an on screen notification stating "Power Surge on USB hub detected. Please disconnect the device." I unplugged all USBs but the message remains. Has anyone else run into this issue?
I have had show up on the screen 3 times. I've mention to ram cares email and they said they haven't heard of this issue.
 

Jsvt3

5thGenRams Supporter
Site Supporter
Joined
Dec 1, 2018
Messages
211
Reaction score
100
Location
Central Pa
Happened to me on Saturday. Only thing plugged in was my wife’s phone. Touched the screen and it went away.
 

Users who are viewing this thread

Top