5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

Mopar’s “Ram Airflow” Cold-Air Intake System For Ram 1500:

UnloosedChewtoy

5thGenRams Supporter
Site Supporter
Joined
Jul 22, 2020
Messages
756
Reaction score
666
Location
South Dakota

Rambro23

Active Member
Joined
Jan 28, 2019
Messages
161
Reaction score
76
Can anyone verify their system lines up like so? Appears to be an unsightly gap, yet everything lines up and clicks into place with no more play. Perhaps they updated this kit?

60AA7AE2-631C-476A-BF05-212D2F19569E.jpeg
 

Rambro23

Active Member
Joined
Jan 28, 2019
Messages
161
Reaction score
76
Ordered through my local dealer, had it in a day. No shipping and used the 15% off Mopar Coupon. Looks great, sounds good, and I can feel a little more responsiveness. And its from Ram so no need to worry about warranty or something breaking from it... I'm happy, end of day thats all that matters guys. Be safe out there. View attachment 80101 View attachment 80102
Mine lines up just like yours on the three tabs (slight gap), yet there appears not to be any adjustment (it's designed to line up as such). What are your thoughts? I saw other folks post pics with theirs lined up flush.
 

Rambro23

Active Member
Joined
Jan 28, 2019
Messages
161
Reaction score
76
Also notice a tab was missing in the middle where the top wedges down from. Doesn't look like it was broken, just left off. Anybody else's this way?
6aa444ffa12e7ab97b653e2681121b18.jpg
Mine is that same way. It seems to prevent the lid from mounting up flush (like the pictures). Does yours also have a slight gap when installed?
 
Joined
Sep 27, 2020
Messages
13
Reaction score
17
Mine looked the same way. Took a table knife and put it under edge and lifted it slightly. Pulled cowl towards front and it slid right in flush. Seems to be a warping issue with front section.
 

Rambro23

Active Member
Joined
Jan 28, 2019
Messages
161
Reaction score
76
Mine looked the same way. Took a table knife and put it under edge and lifted it slightly. Pulled cowl towards front and it slid right in flush. Seems to be a warping issue with front section.
Tried that too (but with plastic trim tools) however, the middle tab on my kit seems to be intentionally missing. Its as if it was redesigned this way for some reason.
 

Rambro23

Active Member
Joined
Jan 28, 2019
Messages
161
Reaction score
76
What did you have to do cause mine was installed by dealer now I’m going to have to adjust it...
I unhooked the three tabs by lifting up the rear lid. Then, standing in front of the truck’s grille, I pulled the top cover toward myself and used a plastic trim tool to pry the top cover over the lip. Took some elbow grease but finally got it right.
 

jrw921

Active Member
Joined
May 5, 2020
Messages
28
Reaction score
11
Location
Texas
You remove the cover by pulling up on the rear and then slide the whole cover back towards the windshield. The tabs will come right out. When re-installing, put the cover on close to the windshield and slide forward insuring the tabs slide under the cowl. Then push down on the rear of the cover to secure. You shouldn't need any pry tools. RamAir1.jpg
 

Amazing93

Active Member
Joined
Aug 30, 2019
Messages
185
Reaction score
140
Has anyone washed their filter yet? If you did what did you do and how did it come out?
 

Users who are viewing this thread

Site Vendors

Members online

Top