5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

How to soft reset 12”UConnect

cipherbreak

Active Member
Joined
Jul 16, 2018
Messages
91
Reaction score
54
I’m sure the guys over at infotainment.com have this figured out. Maybe someone can ask them how to soft reset Uconnect 12.

P.S. Disconnecting the battery is NOT a soft reset.
 

Neurobit

RAM Sorcerer
Joined
Jul 9, 2018
Messages
5,157
Reaction score
3,922
Location
Texas
I bet even the UConnect people don't know how to do this... :unsure:
How can this be such a unicorn, where no one on the entire internet doesn't know how to do this? Baffling.
 

Kemper

New Member
Joined
Jul 25, 2019
Messages
1
Reaction score
0
I bet even the UConnect people don't know how to do this... :unsure:
How can this be such a unicorn, where no one on the entire internet doesn't know how to do this? Baffling.
So did we ever figure this out? Last post of this thread is in July. It's almost October, now I'm having a problem with my 12 inch screen not booting up. Anybody figure out how to do a soft reset?
 

Diamondback

Ram Guru
Joined
Jun 9, 2019
Messages
1,249
Reaction score
553
Location
Midwest
yup we posted months ago how to successfully do a soft and hard reset using the buttons on both the 12 and 8.4

it may be in one of the million other threads, though.
 

predv2

New Member
Joined
Oct 1, 2019
Messages
4
Reaction score
4
I finally figured this out for the Uconnect 12! I honestly looked around for months and never found it, I hope this helps others save time.

Hold down the 'MUTE' and 'SCREEN OFF" for about 30 seconds. Let go and it should reboot.

UPDATE: I can no longer reproduce this. :(

IMG_0079-edit.png
 
Last edited:

jloops

Well-Known Member
Joined
Jan 15, 2019
Messages
474
Reaction score
438
Location
Florida
This doesn’t do anything for me other than turn off the screen or mute the radio. Maybe I’m doing it wrong? Anyone else have any luck?
 

predv2

New Member
Joined
Oct 1, 2019
Messages
4
Reaction score
4
This doesn’t do anything for me other than turn off the screen or mute the radio. Maybe I’m doing it wrong? Anyone else have any luck?
I just went to test it again and it did NOT work this time. I am very perplexed... The only thing I can think of is when I did it the first time the radio was all locked up and either it was luck that it just so happen to reboot or it was enough to tip it over and force a reboot.

Either way, sorry for the bad information... and sad that still no one can answer this. in my 2015 and 2017 it was so easy to reboot when it happened I don't know why they don't allow it now or make it known.
 

Jtr

Ram Guru
Joined
Nov 25, 2018
Messages
575
Reaction score
322
I had a first today-- had Sirius/XM radio, a podcast from my phone AND a track from my phone's media album playing at the same time while connected by USB. Sometimes it was just two things overplaying eachother. What a comedy of errors. Went to hit the power button on the screen and everything still kept playing! I had to disconnect the USB entirely-- and even then over bluetooth I still had sat radio and the podcast playing simultaneously. I had to then pull the vehicle over. Turn off the truck and then restart it to get it working properly. This soft rest option (either discovered or added through an update) can't happen soon enough!!
 

Smurfmobile85

New Member
Joined
Sep 1, 2019
Messages
1
Reaction score
2
Hold VR and Phone buttons on steering wheel for 30 seconds with vehicle in ACC. Then turn vehicle off, open driver door for 30 seconds.
On a road trip and searched for a solution to reboot the state and found this thread. Tried this on our two week old '19 Ram 3500 after nothing was responding and it rebooted the head unit and everything worked great. Thanks for the help!
 

Omlifecrew

Active Member
Joined
Sep 4, 2019
Messages
36
Reaction score
5
On a road trip and searched for a solution to reboot the state and found this thread. Tried this on our two week old '19 Ram 3500 after nothing was responding and it rebooted the head unit and everything worked great. Thanks for the help!
I'm still not able to get mine too reset using these steps. So I held down vr and phone, put car in ac mode, waited 30 seconds, turned off the vehicle, let go of the vr and phone buttons, opened the door, left it open for 30 seconds, closed the door, turned truck back on to acc and run and nothing happened. Anything else I missed?
 

tdwilli1

Member
Joined
May 10, 2018
Messages
22
Reaction score
23
I'm still not able to get mine too reset using these steps. So I held down vr and phone, put car in ac mode, waited 30 seconds, turned off the vehicle, let go of the vr and phone buttons, opened the door, left it open for 30 seconds, closed the door, turned truck back on to acc and run and nothing happened. Anything else I missed?

Did you put the truck in AC mode first?
 

Neurobit

RAM Sorcerer
Joined
Jul 9, 2018
Messages
5,157
Reaction score
3,922
Location
Texas
I had a first today-- had Sirius/XM radio, a podcast from my phone AND a track from my phone's media album playing at the same time while connected by USB. Sometimes it was just two things overplaying eachother. What a comedy of errors. Went to hit the power button on the screen and everything still kept playing! I had to disconnect the USB entirely-- and even then over bluetooth I still had sat radio and the podcast playing simultaneously. I had to then pull the vehicle over. Turn off the truck and then restart it to get it working properly. This soft rest option (either discovered or added through an update) can't happen soon enough!!
This has been happening to me lately as well. XM & BT Audio playing at the same time. Very strange behavior.
 

airgas1998

Well-Known Member
Joined
Jul 13, 2019
Messages
266
Reaction score
123
Location
Iowa
I don't get it you cant simultaneously hold both phone buttons it's either or????or does it not matter as long as one of them is pressed in???
 

airgas1998

Well-Known Member
Joined
Jul 13, 2019
Messages
266
Reaction score
123
Location
Iowa
I'm still not able to get mine too reset using these steps. So I held down vr and phone, put car in ac mode, waited 30 seconds, turned off the vehicle, let go of the vr and phone buttons, opened the door, left it open for 30 seconds, closed the door, turned truck back on to acc and run and nothing happened. Anything else I missed?
it doesn't work for me either...
 

aametzger

Active Member
Joined
Aug 21, 2019
Messages
131
Reaction score
184
Location
Dayton, Ohio
I had an issue today where my uconnect was locked up and wouldn't do carplay and the nav screen was blank as well as other various issues. The issues continued even after powering off the truck a few times as I made stops for fuel and food. When I got home from my trip I tried different combinations of the methods mentioned here to do a soft reset but was unsuccessful. I ended up disconnecting the negative battery terminal, and the nav and carplay came back but it obviously reset all the settings. I have to wait the hour to get the uconnect apps back, and then set back up my preferences.
I will have them check it out at the dealer when I make an appointment for this and a few other items.
 

Users who are viewing this thread

Top