5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

Fog and cargo buttons not working (or illuminating on dash when pressed)

Zac11485

New Member
Joined
Jun 9, 2019
Messages
1
Reaction score
0
Hi all -

first time posting here...The buttons on my 2019 Bighorn that trigger my fog and cargo lights are not working.

The indicator light on either button doesn’t illuminate when pressed and the corresponding icon on the dash doesn’t light up, and either do the actual lights themselves. Is it a fuse? Faulty button? will the warranty cover me bringing it in for the dealership to figure it out?
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,668
Reaction score
1,187
Location
Michigan
Hi all -

first time posting here...The buttons on my 2019 Bighorn that trigger my fog and cargo lights are not working.

The indicator light on either button doesn’t illuminate when pressed and the corresponding icon on the dash doesn’t light up, and either do the actual lights themselves. Is it a fuse? Faulty button? will the warranty cover me bringing it in for the dealership to figure it out?

Hi Zac11485,

I regret to hear of the trouble you are experiencing with your truck! If you are not able to determine a solution based on suggestions provided here and you decide to work with your dealer, please know that our team is just a private message away and we are more than happy to provide you with an additional layer of support while in service.

Mark
RamCares
 

-Nightwind-

Active Member
Joined
Dec 5, 2019
Messages
28
Reaction score
12
Hi all -

first time posting here...The buttons on my 2019 Bighorn that trigger my fog and cargo lights are not working.

The indicator light on either button doesn’t illuminate when pressed and the corresponding icon on the dash doesn’t light up, and either do the actual lights themselves. Is it a fuse? Faulty button? will the warranty cover me bringing it in for the dealership to figure it out?

What ended up happening, Zac? I noticed the same thing today.


Sent from my iPhone using Tapatalk
 

-Nightwind-

Active Member
Joined
Dec 5, 2019
Messages
28
Reaction score
12
Does anyone have any thoughts here?


Sent from my iPhone using Tapatalk
 

AALiVEE

Active Member
Joined
Feb 26, 2020
Messages
31
Reaction score
7
The fog lights only come on when the low-beam is activated, or something like that.
Play around with different switch positions for the headlights and i think you will get a hang of it.
 

Dumpster_on_Wheels

Active Member
Joined
Apr 26, 2020
Messages
50
Reaction score
23
Location
PA
I had the same thing happen the day I got my truck and haven’t been able to replicate since. I don’t think it was any ‘problem’, more me just not getting the understanding of any dependencies.
 

-Nightwind-

Active Member
Joined
Dec 5, 2019
Messages
28
Reaction score
12
I had the same thing happen the day I got my truck and haven’t been able to replicate since. I don’t think it was any ‘problem’, more me just not getting the understanding of any dependencies.

I feel the same way. There has to be something that I’m just not getting. Early this morning, I had it set on auto lights and could not turn in the fogs. I switched to “on” and the fogs would still not turn on. This evening, I was able to turn them on while the switch was back on auto. Idk. Weird.


Sent from my iPhone using Tapatalk
 

Users who are viewing this thread

Top