5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Nsleone

Ram Guru
Joined
Sep 20, 2020
Messages
622
Reaction score
487
Location
Florida
Hello all, I've had my 2020 ram 1500 for about 3 months now (got it new) and I have just over 8200 miles on it with no issues until tonight. Tonight just after pulling out of the driveway the engine light came on and my OBDII reader showed codes P1D73 and U1850. According to the internet those are the front grill shutters (P1D73) and Driver control Module 2 lost communication with Transmission Control Module (U1850). But wait there's more... After disconnecting the battery for a few minutes and reconnecting it the engine light appears to be gone (I only drive it around the block so I am not certain about this) but on top of this the backup camera is not working. The icon for the bakup camera is simply missing and the screen(12 inch) does nothing when the truck is put in reverse. Also for some weird reason my Trailer brake controller setting page is missing from the 12 inch?? What in the world is going on here? If anyone has any idea on these issues please let me know. I plan on taking it in to the dealership tomorrow, and I will update this as things progress.
 

RamCares

Spends too much time on here
Joined
May 3, 2018
Messages
3,861
Reaction score
1,246
Location
Michigan
Hello all, I've had my 2020 ram 1500 for about 3 months now (got it new) and I have just over 8200 miles on it with no issues until tonight. Tonight just after pulling out of the driveway the engine light came on and my OBDII reader showed codes P1D73 and U1850. According to the internet those are the front grill shutters (P1D73) and Driver control Module 2 lost communication with Transmission Control Module (U1850). But wait there's more... After disconnecting the battery for a few minutes and reconnecting it the engine light appears to be gone (I only drive it around the block so I am not certain about this) but on top of this the backup camera is not working. The icon for the bakup camera is simply missing and the screen(12 inch) does nothing when the truck is put in reverse. Also for some weird reason my Trailer brake controller setting page is missing from the 12 inch?? What in the world is going on here? If anyone has any idea on these issues please let me know. I plan on taking it in to the dealership tomorrow, and I will update this as things progress.
Apologies for the trouble, @Nsleone. If it would be of interest, our team is a private message away and we are more than willing to escalate a case on your behalf for further support as you work with your dealer.

Mark
RamCares
 

Nsleone

Ram Guru
Joined
Sep 20, 2020
Messages
622
Reaction score
487
Location
Florida
Apologies for the trouble, @Nsleone. If it would be of interest, our team is a private message away and we are more than willing to escalate a case on your behalf for further support as you work with your dealer.

Mark
RamCares
Thank you for the offer but the issue turned out to be small and was easily fixed
 

Nsleone

Ram Guru
Joined
Sep 20, 2020
Messages
622
Reaction score
487
Location
Florida
Update: Turns out the issue was thankfully a small one. The dealership tech explained to me that the grill shutters in these new ram trucks are somewhat flimsy and prone to failing. Luckily if my truck was not under warranty (which it is) the cost of repair is pretty low. My issue was an internal failure of the grill shutter motor that opens and closes them. That second code (U1850) was tripped by the engine code. Im not sure if this is common knowledge or not but I did not know that when the engine light comes on Auto stop-start is disabled until the issue is resolved and the DTS light is cleared.
 

Users who are viewing this thread

Top