5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

12 Inch Uconnect completely unresponsive

SexyJustice

Member
Joined
Dec 18, 2018
Messages
10
Reaction score
1
Hi guys,
A few months ago I did the dreaded OTA update on my 19 Laramie Sport. Since then it has progressively developed issues over the last few months. Namely, the "Loading Sirusxm Please Wait" screen lock bug happens to me at least a couple of times a week.

However, this evening I ran into a much more serious issue. I started up the truck this evening and the screen was completely dead. The radio still had background functionality but the entire display was dead. Not even the backup camera was displaying. I planned on taking the truck to the dealership for the Sirusxm Please Wait Issue but now I'm more concerned.

Anyone else have the same issue

 

JLaw297

Active Member
Joined
Apr 20, 2020
Messages
25
Reaction score
11
I have a similar issue with screen going completely black with sound, or flashing black every couple minutes and unresponsive. Took it to the dealer and they did an update on it, but no change. They're ordering a new radio and touchscreen.

Wish whatever last update went out wasn't sent because it worked flawlessly until the last couple months. Even with SirusXM.
 

Users who are viewing this thread

Top