5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

12” screen issues

dubp44

New Member
Joined
Aug 19, 2019
Messages
4
Reaction score
0
Anybody else having this screen issue where it goes completely black for no apparent reason? It wasn’t even that dark yet. I was thinking it was going into dark mode, but the screen actually went off. I didn’t shut it off. It turned off on its own. I’m really disappointed in the fact that you spend over 60K for a vehicle and the screen starts shutting off by itself. Unacceptable. Has anyone else had this problem, and if so what was the remedy? Looking to fix this problem ASAP!
 

J-Cooz

Ram Guru
Joined
Jun 28, 2019
Messages
735
Reaction score
495
There's an update coming Q4 apparently to address these issues. I've had mine go black after reversing once. It cleared itself after. It definitely has a few bugs. Hoping they fix them soon
 

dubp44

New Member
Joined
Aug 19, 2019
Messages
4
Reaction score
0
To clarify the issue, I put truck in reverse, and then I put into drive and it went black. So it seems it’s the same issue. It hasn’t happened again. Hopefully it will be fixed in Q4
 

J-Cooz

Ram Guru
Joined
Jun 28, 2019
Messages
735
Reaction score
495
To clarify the issue, I put truck in reverse, and then I put into drive and it went black. So it seems it’s the same issue. It hasn’t happened again. Hopefully it will be fixed in Q4
Exact thing mine did too.
 

JasonB

Active Member
Joined
May 14, 2019
Messages
67
Reaction score
65
No problems with my setup... lets hope it stays that way
 

Nothing2Personal

New Member
Joined
Mar 29, 2019
Messages
3
Reaction score
0
I had mine freeze up. Putting it into reverse showed me the rear camera but when I went back into drive the screen refreshed to the last content but was unresponsive. Restarting the car caused it to work for like half a minute until it froze again. I tried this about 5 times and then I made an appointment for the next day to have it checked out, but it seemed to resolve overnight and I couldn't reproduce the problem. A month later it hasn't reoccurred.
 

brody.cepeaux

Active Member
Joined
Aug 22, 2019
Messages
57
Reaction score
37
Location
Canada
Anybody else having this screen issue where it goes completely black for no apparent reason? It wasn’t even that dark yet. I was thinking it was going into dark mode, but the screen actually went off. I didn’t shut it off. It turned off on its own. I’m really disappointed in the fact that you spend over 60K for a vehicle and the screen starts shutting off by itself. Unacceptable. Has anyone else had this problem, and if so what was the remedy? Looking to fix this problem ASAP!
Best practice is to take it to the dealership and have them open a repair order. They can run diagnostics and report to FCA. Sometimes a flash update will fix it, other time they will just replace a faulty unit.
 

ScottXX

Member
Joined
Sep 5, 2019
Messages
12
Reaction score
4
Same thing happening with me everyday for the last week. Dealer called me an hour ago telling me there’s a star case opened and they expect the fix OTA in the 4th quarter.
 

Users who are viewing this thread

Top