Screen turns off but still functions

ppowell1983

Active Member
Messages
176
Reaction score
109
Points
43
So, today after shifting into reverse or turning on the backup camera manually and then turning off the backup camera the screen turns off and won’t turn on. Although the touch screen still functions. I turned off the truck and turned it back on. It started doing that today. I have a video but i can’t seem to figure out how to attach it. I have an appointment on Tuesday for wind noise, we will see what they say about this. The truck is 3 weeks old




Sent from my iPhone using Tapatalk
 

SynAckuL

Active Member
Messages
131
Reaction score
96
Points
28
I've had the same issue three times now. About 700 miles on the truck.

You can upload the videos to YouTube on your own channel, and then link to them here.
 

Attachments

202snowman

Moderator
Staff member
Site Supporter
Messages
1,035
Reaction score
980
Points
113
Location
Rochester, NY
I had it happen once. Disconnected the battery for 5 min and reconnected and it reset..hasnt happened since
 

pgienger

Member
Messages
22
Reaction score
9
Points
3
Location
ND
Had a similar thing, screen goes black after the camera "switches off," except that in my case I was able to bring it back with either the radio "power" button or the screen off button, don't remember which. Either way, it was fixable and it just stopped doing it... knock on grey colored simulated wood panels...
 

Gesha007

New Member
Messages
4
Reaction score
2
Points
3
Same issue and my Navi won’t work. Service told me to scream and wait for an update. I’ll just hold my breathe for $800 a Month. Lol
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top