5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

Interior Lights not working

RickWaz

Well-Known Member
Joined
Nov 7, 2019
Messages
344
Reaction score
344
Location
42.524603, -83.756544
Nothing...just a part of the design of the console to make it look pretty.
Many thanks to the posters regarding the "red" area of the Interior Light housing that looks like a like BUT does not illuminate because it's simply low-tech eye-candy! It's puzzled me since I got my Ram, NOW I'm simply amazed that FCA added such a wasteful "decoy light"! 😑
 

SpeedyV

Ram Connoisseur
Staff member
Site Supporter
Joined
May 6, 2018
Messages
4,739
Reaction score
4,388
Location
Fort Worth, Texas
I mean, it does give you a nice glow all around when those tiny LEDs light up...
IMG_0035.jpg
 

RickWaz

Well-Known Member
Joined
Nov 7, 2019
Messages
344
Reaction score
344
Location
42.524603, -83.756544
:ROFLMAO: My bad! I missed the usefulness and functionality of that tinier perimeter glow from the tiny LEDs, that an FCA Lighting Engineer designed, perfected and patented. Eat those interior lumens Ford & GMC!!!
 

HALOJUMPER

New Member
Joined
Jul 31, 2020
Messages
2
Reaction score
0
has anyone fixed the issue with the map lights and the tailgate button. its so hard to understand some of these answers you guys post, if the fuses are fine the what is the real problem.
 

securityguy

Legendary member
Joined
Feb 17, 2019
Messages
5,318
Reaction score
3,996
Location
North Florida
has anyone fixed the issue with the map lights and the tailgate button. its so hard to understand some of these answers you guys post, if the fuses are fine the what is the real problem.
What issue? Did you check the button in the overhead console? Is your switch set to allow the interior lights to turn on?
 

HALOJUMPER

New Member
Joined
Jul 31, 2020
Messages
2
Reaction score
0
I was having issues with the map lights and the tailgate button not working on overhead panel. However the rear window still worked. Took panel off under steering wheel and checked the F33, F31, and F30 fuses. All were good, but just plugging them back in seem to fix the issue. Had some loose fuses under the hood as well. So hopefully that will help anyone having same issues.
hi i have the same issue, did this fix the problem. or did you have to take it to the deal.
 

Muadib138

New Member
Joined
Nov 10, 2020
Messages
1
Reaction score
0
I'm having the same issues as of today. Front lights did not turn on when I opened the door. The rear seat lights were on. When I tried to adjust the dome buttons many were not working. I could not turn on the down lights manually and the mirror off and lights on buttons were not working and there was no light showing when pressing multiple times. The SOS and help buttons are also not functioning. I will check the fuses tomorrow.
 

sparky95969

New Member
Joined
Mar 14, 2021
Messages
1
Reaction score
0
Just bought the truck yesterday. We got home in the dark and noticed no dome lights in the front. Makes me question my decision on the whole purchase.
Checked all the fuses and still no lights. Going to head back to the dealership tomorrow, probably won't get anywhere on a Sunday. I'm hoping I am just missing something.

Sent from my SM-N986U using Tapatalk
 

2019REBEL

Spends too much time on here
Joined
Jan 28, 2018
Messages
2,003
Reaction score
969
Location
ON, Canada
Just bought the truck yesterday. We got home in the dark and noticed no dome lights in the front. Makes me question my decision on the whole purchase.
Checked all the fuses and still no lights. Going to head back to the dealership tomorrow, probably won't get anywhere on a Sunday. I'm hoping I am just missing something.

Sent from my SM-N986U using Tapatalk


Dome lights are turned on in the center stack on the roof. Look for a button with a door open.
 

Lburnham

New Member
Joined
Mar 31, 2021
Messages
3
Reaction score
1
I was having issues with the map lights and the tailgate button not working on overhead panel. However the rear window still worked. Took panel off under steering wheel and checked the F33, F31, and F30 fuses. All were good, but just plugging them back in seem to fix the issue. Had some loose fuses under the hood as well. So hopefully that will help anyone having same issues.
I am having the same problem when I went to pull panel of under steering wheel, I removed two obvious screw, but still resisting, what else is holding that thing on there?
 

lijok

New Member
Joined
Mar 4, 2019
Messages
1
Reaction score
0
I am having the same problem when I went to pull panel of under steering wheel, I removed two obvious screw, but still resisting, what else is holding that thing on there?
Plastic clips. Just pull it out slowly from the corners and they'll will snap out.
I have the same issue and all the fuses look fine. Service coming up in a few 100 miles, so will have to have the dealer take a look :(
 

securityguy

Legendary member
Joined
Feb 17, 2019
Messages
5,318
Reaction score
3,996
Location
North Florida
Are you all sure that the rheostat that controls the brightness by the headlight knob isn’t all the way down and that the switch in the overhead console is set to turn on when the door is open??? It is typically user error on this and nothing wrong with the truck.
 
Last edited:

Rcwags10

New Member
Joined
Sep 13, 2019
Messages
4
Reaction score
0
hi i have the same issue, did this fix the problem. or did you have to take it to the deal.
Hello, I have the same problem. I pulled the 3 fuses mentioned and checked them and they are all good. Still having the same issue. Any other advice on how to resolve this problem?
 

drew7811

Active Member
Joined
Jan 14, 2020
Messages
52
Reaction score
34
My interior overhead map lights as well as the tailgate button aren't working in the overhead panel. I see the two screws above the sunglasses holder to remove, but are there any others besides that or does the overhead panel just pop down? I am always leery to put a lot of pressure to pull a plastic panel down in fear of breaking something.
 

Rcwags10

New Member
Joined
Sep 13, 2019
Messages
4
Reaction score
0
My interior overhead map lights as well as the tailgate button aren't working in the overhead panel. I see the two screws above the sunglasses holder to remove, but are there any others besides that or does the overhead panel just pop down? I am always leery to put a lot of pressure to pull a plastic panel down in fear of breaking something.
Remove the 2 screws and just pull down. It is held in with 6 other clips that should release very easy.
curious, did you just recently have an update with your Uconnect? I’m reading that a lot of other people who have this same issue, noticed they had an Update done recently.
Im going to try to take the whole center console down and reseat the connections. Many others state this worked for them.
 

drew7811

Active Member
Joined
Jan 14, 2020
Messages
52
Reaction score
34
Remove the 2 screws and just pull down. It is held in with 6 other clips that should release very easy.
curious, did you just recently have an update with your Uconnect? I’m reading that a lot of other people who have this same issue, noticed they had an Update done recently.
Im going to try to take the whole center console down and reseat the connections. Many others state this worked for them.
I took my overhead panel down and disconnected both wiring harnesses. I plugged them back in and amazingly the lights and tailgate release are all working (knock on wood).
 

INgmar

New Member
Joined
Jan 23, 2020
Messages
1
Reaction score
1
Anyone here still have the problem with overhead map light an tailgate button not working??
I unplugged and reconnected the console, but this just works for few ours, sometimes days.
There has to be a fix for this problem. The complete overhead console and BCM were already changed in my RAM...still the same problem!
 
Joined
Sep 27, 2020
Messages
13
Reaction score
17
My interior overhead map lights as well as the tailgate button aren't working in the overhead panel. I see the two screws above the sunglasses holder to remove, but are there any others besides that or does the overhead panel just pop down? I am always leery to put a lot of pressure to pull a plastic panel down in fear of breaking something.
I had this exact same problem. Took truck to dealer under warranty and they discovered that the sunroof drain had a kink in it not allowing water to drain so the water drained down the inside of B pillar and caused wire connections to corrode that control that module. They replaced the bad wiring and haven’t had any problems since then. It was a two-day affair due to specialist having to come in and determine drain problem and then coming back to get wiring fixed. Hope this helps.
 

popstatwo

Active Member
Joined
Jul 24, 2021
Messages
70
Reaction score
25
My dome lights were working and then I adjusted the brightness on the interior lights while I was driving last night cause it was very bright. Ever since I did that, the dome lights aren’t working anymore. I’ve read the thread and tried everything and nothing works. The lights do work when I manually press the specific light button for each, but not when the doors open.
 

Attachments

  • 3290AEDF-2FB7-40FF-8288-75A8127FF58E.jpeg
    3290AEDF-2FB7-40FF-8288-75A8127FF58E.jpeg
    168 KB · Views: 11
  • E0C15437-295C-4194-8AD7-164DF76F1E05.jpeg
    E0C15437-295C-4194-8AD7-164DF76F1E05.jpeg
    111.4 KB · Views: 10

securityguy

Legendary member
Joined
Feb 17, 2019
Messages
5,318
Reaction score
3,996
Location
North Florida
My dome lights were working and then I adjusted the brightness on the interior lights while I was driving last night cause it was very bright. Ever since I did that, the dome lights aren’t working anymore. I’ve read the thread and tried everything and nothing works. The lights do work when I manually press the specific light button for each, but not when the doors open.
The brightness control in PIC 1 actually has nothing to do with the dome lighting...only the switch in PIC 2.
 

Users who are viewing this thread

Top