12” Software update is out

MJP

Ram Guru
Messages
790
Reaction score
226
Points
43
Location
New Jersey
How long to the update take? My dealership just call and told me it will take about 5 hours.
Has anyone confirmed that the update does anything significant enough to justify having it done? Particularly, if it takes 5 hours.
 

hemiguy37

Member
Messages
7
Reaction score
3
Points
3
Had my updates last Wednesday, now every time I back up and shift back to park the screen goes out. I have to turn the radio off and on to get the screen to work. Also now my nav isn't working. It won't find the GPS signals. Ugh..... not sure if they are related but too coincidental.
Well I think I fixed my problems. Probably not what they want you to do, but it worked. Disconnected negative then positive battery terminals, waited a few minutes then reconnected. Started the car and waited. Be warned the car takes its time to refind all installed options. For example I had no climate control or other things, it was weird, but like a normal computer reboot it got there and all seems fine now. None of the issues I was having. The version is still the updated one. Just my experience.
 

Rebel Soul

5thGenRams Supporter
Site Supporter
Messages
13
Reaction score
16
Points
3
Has anyone confirmed that the update does anything significant enough to justify having it done? Particularly, if it takes 5 hours.
I did mine and after that no navigation is working....from bad to worse. Takes approximately 40 min to 1 hour.
All Uconnect/Guardian/App/HK/ ....are worthless. No one care about all those problems we have....called / Guardian( haha) Uconnect.....and all of them addressing you to dealership which you have to follow them protocols....appointment..again appointment and is just wasting your time...
Good luck to everyone!!
 

MJP

Ram Guru
Messages
790
Reaction score
226
Points
43
Location
New Jersey
I did mine and after that no navigation is working....from bad to worse. Takes approximately 40 min to 1 hour.
All Uconnect/Guardian/App/HK/ ....are worthless. No one care about all those problems we have....called / Guardian( haha) Uconnect.....and all of them addressing you to dealership which you have to follow them protocols....appointment..again appointment and is just wasting your time...
Good luck to everyone!!
That confirms it for me - no update!
 

TMD78

Member
Messages
14
Reaction score
2
Points
3
I’m on day 12 without my $62k truck thanks to the failed software update. Apparently my new radio unit still hasn’t shown up to be replaced, absolutely ridiculous. Can’t imagine I will ever ask them to check for an update again in the future if this is the risk.
 

grinch72

Well-Known Member
Messages
403
Reaction score
262
Points
63
Beware!

That’s the update that killed my navigation

STAR rep said it fixed nearly all problems for a client

It fixed my xm preset problems (maybe) but now my screen goes blank or stays blank after starting car. Have to hit power button twice to get the screen to come on
This killed my nav as well. Did you ever get it fixed?
 

Rebel Soul

5thGenRams Supporter
Site Supporter
Messages
13
Reaction score
16
Points
3
Dealership said wait for the new update and the navigation will work normal again!!! WTF !!!
The whole call situation is a pink-pong ....I’m so close to give up in any empty promises!!!
Fck ******** !!!:mad:
 

Hawgdawgn

New Member
Messages
3
Reaction score
0
Points
1
All, had the update on my 19 Longhorn and nav works about every other drive, very unreliable. This is a new problem since the update. While voice control worked much better, still no vehicle health reports, live search, etc. Techs are as frustrated as we are. Might be headed for a replacement radio. Has anyone that had radio replaced seen an end to these issues or do they follow the hardware?
 

jloops

Active Member
Messages
172
Reaction score
85
Points
28
Location
Florida
I had the Uconnect TSB 08-009-19_REV.A done last month. My screen now goes blank about 75% of the time (after startup) when I use the backup camera. Took it back to the dealership last Thursday/ Friday and they did another TSB 18-19-90-92 for the CVPM module and said the issue was resolved, but it isn't I'm still having the issue.

Happened again Saturday, Sunday and again this morning so I drove straight to the dealership so they could see it happening. The service manager comes out and looks at it then tells me he'll call Uconnect and get back to me. I told him I want documentation to show I brought it in and it's not working properly. He said you don't have an appointment, so I told him fine I would go home make an appointment and bring it back tomorrow morning. He said he wouldn't accept my appointment and now refuses to service my truck.

I've had a case open with RamCares, the case manager spoke with the service manager and service director, they told her I should take my truck back to where I bought it and let them service it or talk to them about trading it in on a new truck. I spoke with the GM and he was going to speak with the service manager then get back to me.

I strongly discourage anyone considering having the TSB 08-009-19_REV.A done not to do it. FCA/ Uconnect is just grabbing at straws hoping it will resolve issues, but really they have no clue what's causing issues or how to fix them.
 
  • Like
Reactions: MJP

MarvinK

Member
Messages
13
Reaction score
2
Points
3
I’m on day 12 without my $62k truck thanks to the failed software update. Apparently my new radio unit still hasn’t shown up to be replaced, absolutely ridiculous.
They tried to update mine yesterday and it killed the radio. It basically just shows cycles between the RAM logo, SiriusXM logo and a black screen. I assume it keeps rebooting.

The dealer ordered a replacement unit, but said they don’t have visibility into tracking on this type of part.

Pretty disgusted with the software on this truck—between the glitchy hotspot, $20/month for basic mobile app functions, and now bricked stereo. I will never buy another vehicle with uConnect It is too bad—because the truck is beautiful inside and out.
 

TMD78

Member
Messages
14
Reaction score
2
Points
3
Welcome to the party folks! I finally received my truck back today (day 21). It takes a long time for the parts to show up and as mentioned above, FCA has the shoddiest tracking I’ve ever heard of. I haven’t had time yet to see what is glitchy or not, but right off the bat I was happy to see I actually have the “rebel theme” on my rebel truck which includes my 7” display cluster! I will have to check the software version this came loaded with and all the expected quirks but am half afraid to do so. Mostly I’m happy to have my truck so I can finally do some weekend camping with our travel trailer.
 

TMD78

Member
Messages
14
Reaction score
2
Points
3
31752
Here is my supposedly new build radio software info, took 21 days as I keep mentioning for it to show up. Apparently they don’t replace the screen because I noticed my glass screensaver is still intact.
 

Edwards

Ram Guru
Messages
1,761
Reaction score
1,713
Points
113
Location
TX
View attachment 31752
Here is my supposedly new build radio software info, took 21 days as I keep mentioning for it to show up. Apparently they don’t replace the screen because I noticed my glass screensaver is still intact.
Does the new SW do any new tricks or does it just work as advertised?
 

azzx

Active Member
Messages
111
Reaction score
35
Points
28
Location
AZ
In my case no demonstrable value with this update.
Just a 6 hr first failed attempt with a dead screen!
2nd attempt took 30 minutes
However most of the bugs were not terminated and new bugs added!
The whole thing is a mediocre integration of different hardware and software from many diff. vendors.
 
Last edited:

TMD78

Member
Messages
14
Reaction score
2
Points
3
Can’t say anything has changed, I do have the theme option that goes with my rebel (wasn’t there previously) and currently there are no station logos on sirusXM. I feel like I don’t want to dig too deep though.
 

gwarrior4u

Member
Messages
5
Reaction score
3
Points
3
Hello All,

Purchased my 2019 RAM Limited in Oct 2018. Have had issues with 12" screen since new. ( starting on the preview channel --- 360L not working --- bluetooth drop outs ect) They did the May software update a few weeks ago. The unit was working a bit better. The starting on the preview channel had stopped BUT yesterday I got in the truck in the morning and no sound through the radio! No bluetooth sound, no radio , nothing!

I took it back to the dealer and the service writer witnessed the issue. There were error codes stored as well. Then the next morning when the tech started the vehicle he claims it was working fine. He found the stored error codes and has started a new STAR case. See attached that explains a related issue they claim is part of the problem. The error codes noted are the same error codes the tech said was stored....
I called the dealer with the star case # this morning. The guy got very stubborn and obnoxious (I need to find a new dealer), but finally looked up the case # and agreed that it's there. He said the fix for Q4 will not arrive until October. Guess I'll live with it until then. I couldn't see wasting a day at the dealer if the fix wasn't available.
 
Last edited:

Gman

5thGenRams Supporter
Site Supporter
Messages
930
Reaction score
633
Points
93
Location
Highlands Ranch, CO
Wasn't having any issues.

... And then this morning I started my truck and no presets. They won't save.

Whee!

Testing is overrated. The rapid release cycle is apparently more important.
 

tdager

Active Member
Messages
54
Reaction score
52
Points
18
Wasn't having any issues.

... And then this morning I started my truck and no presets. They won't save.

Whee!

Testing is overrated. The rapid release cycle is apparently more important.
Welcome to "agile" development!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top