5thGenRams Forums

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • We have been battling an on and off issue with registration verification emails not being sent out with certain users. We have finally got the issue resolved so if you have tried registering for the site but have not received a verification email, just request another verification email when you log in and you should now receive it. If you still don't receive the verification email, send us an email at [email protected] and we will get it resolved for you. Thanks!

12" screen constantly reboots

Geobound

Active Member
Joined
Sep 25, 2019
Messages
45
Reaction score
23
I have had a few quirks with the radio since owning it, but always thought that I was just imagining some of the issues....................well today that all changed.

For some reason my 12" screen is stuck in a reboot mode. It starts up normally and will function properly for about 2 minutes, but then power down and start up again.

The GPS will come up with me in a city 2 hours away (briefly), and then eventually locate me................well kind of. It puts me in the middle of a lake, but at least the lake is close to where I am?

I will obviously be taking this to my dealer when I get back home (I'm on holidays this week), but thought that I would see if anybody else had the same problems?
 

Dallas Aggie

Member
Joined
Dec 26, 2018
Messages
14
Reaction score
10
I have the same rebooting issue. Took it to the dealer and they believe the radio needed to be replaced. They ordered the radio and Chrysler put it on hold saying there is a December software update that will fix it.

Obviously waiting until December is not a solution and I had to call Ram Cares and get them involved. Long story short they think the radio will be replaced tomorrow and I will get my truck back. Tomorrow will be day 27 that they have had my truck.

One workaround that worked for me was to have my phone plugged in before starting the truck so that CarPlay would take over. If I did that the radio would not reboot. Plugging the phone in after I started the truck would not work.

Good luck.
 

Geobound

Active Member
Joined
Sep 25, 2019
Messages
45
Reaction score
23
I have the same rebooting issue. Took it to the dealer and they believe the radio needed to be replaced. They ordered the radio and Chrysler put it on hold saying there is a December software update that will fix it.

Obviously waiting until December is not a solution and I had to call Ram Cares and get them involved. Long story short they think the radio will be replaced tomorrow and I will get my truck back. Tomorrow will be day 27 that they have had my truck.

One workaround that worked for me was to have my phone plugged in before starting the truck so that CarPlay would take over. If I did that the radio would not reboot. Plugging the phone in after I started the truck would not work.

Good luck.


Sorry for the delay, but I was away on holidays.

I use an iPhone and didn't have any problems with it, then my brother plugged in his Samsung in the second port and that's when the problem started.

I don't know if its a coincidence or not, but that's what I've noticed.

Plugging in my iPhone before starting the truck almost always takes care of the problem, but I've had several instances where it didn't. I'm just back from holidays today's, so I will stop in at my local dealer tomorrow to see if they can do anything or not.

Thanks for your reply though, that was helpful. (y)
 

Geobound

Active Member
Joined
Sep 25, 2019
Messages
45
Reaction score
23
Just got my truck back and they replaced the radio. So far so good with no reboots.


It concerns me that they had your truck for 3 weeks, I hope it was for more than just the radio? Did they supply you with a loaner as well?
 

moosem

Ram Guru
Joined
Nov 19, 2018
Messages
891
Reaction score
878
Location
Rhode Island
I have the 8.4 but I had the same issue, accept mine would reboot exactly every four minutes. As it turns out, it was a corrupted file on my USB flash drive that I left plugged in all the time. Unplugged the thumb drive, no problems, plug it back in, reboot every four minutes like clockwork. I deleted all of the files on the drive and reinstalled them and haven’t had any problems since.
 

Geobound

Active Member
Joined
Sep 25, 2019
Messages
45
Reaction score
23
I have the 8.4 but I had the same issue, accept mine would reboot exactly every four minutes. As it turns out, it was a corrupted file on my USB flash drive that I left plugged in all the time. Unplugged the thumb drive, no problems, plug it back in, reboot every four minutes like clockwork. I deleted all of the files on the drive and reinstalled them and haven’t had any problems since.


I don't have anything plugged into mine, but thanks for the suggestion.

Total coincidence I'm sure, but when I went out to my truck tonight to take a few interior pictures my iPhone froze up.

I got the popup message on the 12" screen asking me if I want to pair my phone (why it does that every time I turn my truck on I'll never know), but as soon as it showed up tonight my iPhone froze and only a hard reboot would fix it?

Still I love my truck! (y)
 

Dallas Aggie

Member
Joined
Dec 26, 2018
Messages
14
Reaction score
10
It concerns me that they had your truck for 3 weeks, I hope it was for more than just the radio? Did they supply you with a loaner as well?

Got a loaner but definitely not as nice as mine. I had some other items as well, holdup was lack of parts availability and the need to escalate the radio to Chrysler as they initially would not authorize the replacement as they say there is a December software update that would have resolved my issue.
 

Users who are viewing this thread

Top