From bad to worse

RHut

Member
Messages
20
Reaction score
5
Points
3
So I finally got my software updated this morning. Now I don’t have NAV or ANY XM stations. The XM stations all say I need to upgrade my service. I call XM and they say it’s a known problem to the RAM 12 inch screens.

I’m so frustrated. How can a $60,000 vehicle that was released 6 months ago not have bugs like this worked out?

When I use the reverse camera app I cannot get it to return to the radio screen. There are no buttons to push to return to the previous screen.

The next time I bring it in it will be the third visit to fix a radio!
 

JDBob35a

Active Member
Messages
92
Reaction score
77
Points
18
Location
Missouri
So I finally got my software updated this morning. Now I don’t have NAV or ANY XM stations. The XM stations all say I need to upgrade my service. I call XM and they say it’s a known problem to the RAM 12 inch screens.

I’m so frustrated. How can a $60,000 vehicle that was released 6 months ago not have bugs like this worked out?

When I use the reverse camera app I cannot get it to return to the radio screen. There are no buttons to push to return to the previous screen.

The next time I bring it in it will be the third visit to fix a radio!
I feel your frustration, LOTS of bugs in these things. Yesterday I was on the phone twice for a total of about three hours with FCA and Sirius Support just to change the email address associated with my Uconnect account. (Dealer set it up for me and used the wrong address).
I agree totally with the $60,000 statement, I don't' think they spent the time to thoroughly test/debug new new 12" system, and after my calls yesterday they should have kept Sirius out of it for anything other than radio service. The customer shouldn't be caught in the middle of a finger pointing contest to fix these issues.
 

202snowman

Moderator
Staff member
Messages
1,031
Reaction score
975
Points
113
Location
Rochester, NY
So I finally got my software updated this morning. Now I don’t have NAV or ANY XM stations. The XM stations all say I need to upgrade my service. I call XM and they say it’s a known problem to the RAM 12 inch screens.

I’m so frustrated. How can a $60,000 vehicle that was released 6 months ago not have bugs like this worked out?

When I use the reverse camera app I cannot get it to return to the radio screen. There are no buttons to push to return to the previous screen.

The next time I bring it in it will be the third visit to fix a radio!
Kind of in the same boat. They replaced my radio about 3-4 weeks ago, and now no presets for Sirius will save, and obviously I can't toggle through them. According to STAR, this is a known software issue in this version.

Even better, the dealer has been trying to get the centerline to show up in my reverse camera. They've now replaced the radio, replaced the central vision processing module, and now are in the process of the forward facing camera module. I'm on day three at the dealer for the forward facing camera module, as they can't get it to program...they've been on the phone for the last two days with STAR.

I'm getting close to contacting a lawyer at this point. I need a few more days in the shop or one more time trying to fix this problem before I can try lemon law.

Love the truck when it works, unfortunately its spending too much time in the shop.
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
Have you guys experienced an issue where you cannot set presets or favorites while in Sirius? My radio was just replaced and ever since I cannot do either. My old radio did not have this issue. The Dealer says FCA is saying it's a Sirius issue. Getting tired of having to scroll through 900+ channels to change the station.
 

RHut

Member
Messages
20
Reaction score
5
Points
3
So I finally got my software updated this morning. Now I don’t have NAV or ANY XM stations. The XM stations all say I need to upgrade my service. I call XM and they say it’s a known problem to the RAM 12 inch screens.

I’m so frustrated. How can a $60,000 vehicle that was released 6 months ago not have bugs like this worked out?

When I use the reverse camera app I cannot get it to return to the radio screen. There are no buttons to push to return to the previous screen.

The next time I bring it in it will be the third visit to fix a radio!
Update:

I upgraded Xm to all access and now my radio works and I can save presets

Yay!!!!

Navigation still doesn’t work

All i get is the five dots that blink on the screen

Yuuuuuuuck!!!
 

202snowman

Moderator
Staff member
Messages
1,031
Reaction score
975
Points
113
Location
Rochester, NY
Have you guys experienced an issue where you cannot set presets or favorites while in Sirius? My radio was just replaced and ever since I cannot do either. My old radio did not have this issue. The Dealer says FCA is saying it's a Sirius issue. Getting tired of having to scroll through 900+ channels to change the station.

Yes I'm having the problem. According to a response I've seen from STAR at my dealer, they say its a software issue withnthe latest version of software
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
Yes I'm having the problem. According to a response I've seen from STAR at my dealer, they say its a software issue withnthe latest version of software
Thanks. Ironically, I just spoke to my Service Manager earlier and he said he has no update on my issue. I go home and try setting presets and favorites and low and behold it works. Unfortunately, I also lost my remote command ability. This stuff is unbelievable. Why can’t Surius or FCA get it together.
 

202snowman

Moderator
Staff member
Messages
1,031
Reaction score
975
Points
113
Location
Rochester, NY
Thanks. Ironically, I just spoke to my Service Manager earlier and he said he has no update on my issue. I go home and try setting presets and favorites and low and behold it works. Unfortunately, I also lost my remote command ability. This stuff is unbelievable. Why can’t Surius or FCA get it together.
Just for your background...there's a lot more to my STAR case but you can see the response from STAR on the presets
26082
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
Thanks for the info. Fortunately, my presets and favorites have been working fine since yesterday. I just spent 2 hours on the phone with Uconnect and then Sirius trying to get some answers re what happened to my remote commands. No help of course. Anyone @RamCares out there that can help?
 

RHut

Member
Messages
20
Reaction score
5
Points
3
So I have the option of a radio with presets
OR
Navigation

Also today I backed up using the rear view camera

When I put the car back into drive the entire screen went dark and I had to turn the radio back on. When it came back on the screen remained dark for a couple of minutes before the screen came back on.

It’s baffling to me how they are letting this go on. It has to be bad for future sales.
 

RHut

Member
Messages
20
Reaction score
5
Points
3
So I have the option of a radio with presets
OR
Navigation

Also today I backed up using the rear view camera

When I put the car back into drive the entire screen went dark and I had to turn the radio back on. When it came back on the screen remained dark for a couple of minutes before the screen came back on.

It’s baffling to me how they are letting this go on. It has to be bad for future sales.
So I have the option of a radio with presets
OR
Navigation

Also today I backed up using the rear view camera

When I put the car back into drive the entire screen went dark and I had to turn the radio back on. When it came back on the screen remained dark for a couple of minutes before the screen came back on.

It’s baffling to me how they are letting this go on. It has to be bad for future sales.
I’m now starting to think that most of my problems are associated with the fact that I bought this truck used. Three different phone calls have told me that the truck is still under the previous owners name when I give them the vin number (uconnect, SiriusXM, and Guardian). I keep having to fax a copy of my registration to prove that I now am the new owner!

Crazy!
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
Thanks for the info. Fortunately, my presets and favorites have been working fine since yesterday. I just spent 2 hours on the phone with Uconnect and then Sirius trying to get some answers re what happened to my remote commands. No help of course. Anyone @RamCares out there that can help?
Update: my remote commands magically came back and are functioning fine but I lost my SOS and Assist functions. Wtf? I spent another almost hour on the phone late last night with some idiot supervisor at Sirius Guardian who insisted my issues were hardware related and said I need to go to the dealer. How is it possible that the remote commands work but no call buttons work now when they all use the telematics module? The supervisor was clueless. Anyway, I kept trying the SOS and Assist buttons this morning and after about 4/5 tries each I finally got a "needs to be activated" prompt on the screen. I followed the prompts and tested the call buttons and what do you think - they worked. Hardware issue? Sirius and Uconnect are up there with the worst services I've ever come across in my lifetime. So the bottom line is I spent 7 months trying to resolve these issues to included a radio swap and it all boils down a problem on their end. I could have saved myself about 20+ phone calls to Sirius and Ucoonect, many hours of troubleshooting, a radio swap and months without the ability to use remote commands if Sirius would get there act together and own the problem and find a fix. I am happy to report that my radio and all features work fine as of 8:00am this morning.
 

RHut

Member
Messages
20
Reaction score
5
Points
3
Update: my remote commands magically came back and are functioning fine but I lost my SOS and Assist functions. Wtf? I spent another almost hour on the phone late last night with some idiot supervisor at Sirius Guardian who insisted my issues were hardware related and said I need to go to the dealer. How is it possible that the remote commands work but no call buttons work now when they all use the telematics module? The supervisor was clueless. Anyway, I kept trying the SOS and Assist buttons this morning and after about 4/5 tries each I finally got a "needs to be activated" prompt on the screen. I followed the prompts and tested the call buttons and what do you think - they worked. Hardware issue? Sirius and Uconnect are up there with the worst services I've ever come across in my lifetime. So the bottom line is I spent 7 months trying to resolve these issues to included a radio swap and it all boils down a problem on their end. I could have saved myself about 20+ phone calls to Sirius and Ucoonect, many hours of troubleshooting, a radio swap and months without the ability to use remote commands if Sirius would get there act together and own the problem and find a fix. I am happy to report that my radio and all features work fine as of 8:00am this morning.
Today all my fm presets were erased. Crap!
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
Today all my fm presets were erased. Crap!
Don’t panic. It’s a Sirius issue but they won’t admit it or provide any help. It will correct itself. I went through 7 months of pain trying to get my radio issues resolved when all along it was a Sirius problem.
 

MJP

Ram Guru
Messages
767
Reaction score
218
Points
43
Location
New Jersey
How did Sirius fix it?
They didn’t actually do anything that I’m aware of. It just magically fixed itself after many phone calls and hours on the phone with them. Maybe they pushed some sort of update but I went from not being able to set presets or favorites and no Uconnect/SOS/Assist command functions to everything working fine.
 

RHut

Member
Messages
20
Reaction score
5
Points
3
They didn’t actually do anything that I’m aware of. It just magically fixed itself after many phone calls and hours on the phone with them. Maybe they pushed some sort of update but I went from not being able to set presets or favorites and no Uconnect/SOS/Assist command functions to everything working fine.
I’m getting a new radio! I guess after four or five trips to the dealership they have concluded that they cannot fix it
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top