12" uconnect nav issues

Joined
Jun 25, 2018
Messages
31
Likes
44
Points
18
Age
35
#1
Hello,

Just got my 2019 Limited last week, and my navigation is hit or miss if it works. Sometimes I'll turn the truck on and it will fire up no problem, a majority of the time when i hit nav i just get the animated white dots in the middle of the screen like it's trying to load and it never does. also when the nav does work and i change settings and add my home or other addresses they don't save after i turn the truck off and go back to the navigation next time i drive it. anyone else with similar issues? kinda afraid to take it to the dealership since they messed up my 2016 Rebel which resulted in a lemon.
 
Joined
Apr 15, 2018
Messages
1,522
Likes
653
Points
113
#2
Hello,

Just got my 2019 Limited last week, and my navigation is hit or miss if it works. Sometimes I'll turn the truck on and it will fire up no problem, a majority of the time when i hit nav i just get the animated white dots in the middle of the screen like it's trying to load and it never does. also when the nav does work and i change settings and add my home or other addresses they don't save after i turn the truck off and go back to the navigation next time i drive it. anyone else with similar issues? kinda afraid to take it to the dealership since they messed up my 2016 Rebel which resulted in a lemon.
what lemon issue did u have?
 
Joined
Apr 15, 2018
Messages
1,522
Likes
653
Points
113
#5
Did you actually have to trade your rebel in or did they buy it back or did a change of collateral etc
 
Joined
Jun 25, 2018
Messages
31
Likes
44
Points
18
Age
35
#7
Did you actually have to trade your rebel in or did they buy it back or did a change of collateral etc
i surrendered it, so yeah technically a buy back. and the money from the settlement went to the down payment of this truck
 

RamCares

Active Member
Joined
May 3, 2018
Messages
173
Likes
123
Points
43
Location
Michigan
#9
Hello,

Just got my 2019 Limited last week, and my navigation is hit or miss if it works. Sometimes I'll turn the truck on and it will fire up no problem, a majority of the time when i hit nav i just get the animated white dots in the middle of the screen like it's trying to load and it never does. also when the nav does work and i change settings and add my home or other addresses they don't save after i turn the truck off and go back to the navigation next time i drive it. anyone else with similar issues? kinda afraid to take it to the dealership since they messed up my 2016 Rebel which resulted in a lemon.
Hi limited_19,
We understand that you are just reaching out to other forum members to see if anyone is having a similar experience. However, if you do change your mind and wish to take your truck to the dealer, we would be more than happy to add an additional layer of assistance. Our teams will work in tandem with your dealer to support you while your vehicle is being looked at.
Julie
Ram Social Care Specialist
 
Joined
Jun 25, 2018
Messages
31
Likes
44
Points
18
Age
35
#10
Hi limited_19,
We understand that you are just reaching out to other forum members to see if anyone is having a similar experience. However, if you do change your mind and wish to take your truck to the dealer, we would be more than happy to add an additional layer of assistance. Our teams will work in tandem with your dealer to support you while your vehicle is being looked at.
Julie
Ram Social Care Specialist

The dealership still couldn't get this resolved and my navigation system is pretty much useless. They said it's too new and just deal with it until they get more familiar with the system. Spent this much money on this glamorous system and still works like ****. I hope I didn't make a mistake by re purchasing another RAM after my lemon buyback of my previous RAM.
 

Twoamen

Active Member
Joined
May 12, 2018
Messages
176
Likes
43
Points
28
#11
Hang in there bud. Frustration I know but it is new, (I think Panasonic makes the unit) ask them to swap out the radio. See if it helps. Also try a different dealer, tell them your goto dealer is shafting you. Keep the heat on them.. A squeaky wheel gets the oil. I have trivial issue compared to you, but jumped through hoops until it was a was because no one was up on map static desplay.
 
Joined
Apr 15, 2018
Messages
1,522
Likes
653
Points
113
#13
The dealership still couldn't get this resolved and my navigation system is pretty much useless. They said it's too new and just deal with it until they get more familiar with the system. Spent this much money on this glamorous system and still works like ****. I hope I didn't make a mistake by re purchasing another RAM after my lemon buyback of my previous RAM.
Have you tried disconnecting your battery?
 
Joined
Nov 5, 2018
Messages
4
Likes
0
Points
1
Age
46
#16
Hello,

Just got my 2019 Limited last week, and my navigation is hit or miss if it works. Sometimes I'll turn the truck on and it will fire up no problem, a majority of the time when i hit nav i just get the animated white dots in the middle of the screen like it's trying to load and it never does. also when the nav does work and i change settings and add my home or other addresses they don't save after i turn the truck off and go back to the navigation next time i drive it. anyone else with similar issues? kinda afraid to take it to the dealership since they messed up my 2016 Rebel which resulted in a lemon.
 
Joined
Nov 5, 2018
Messages
4
Likes
0
Points
1
Age
46
#17
Having the EXACT same issues on my 2019 Ram Rebel... navigation works only sometimes... often inoperable and screen says "loading" and shows image of earth. Unable to change and save navigation preferences or HOME or WORK address. Addresses will save during current drive, but as soon as truck is turned off preferences are erased.
 

Users Who Are Viewing This Thread (Users: 1, Guests: 0)

Top